webpin/debian/rules
Nathan Bonnemains d723bcf5c7 Add debian rules
2019-04-22 18:11:45 +02:00

29 lines
810 B
Makefile
Executable file

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
%:
dh $@
override_dh_auto_clean:
rm -rf debian/build
override_dh_auto_configure:
mkdir -p debian/build
cd debian/build && meson --prefix=/usr ../..
override_dh_auto_build:
cd debian/build && ninja -v
override_dh_auto_test:
cd debian/build && ninja test
override_dh_auto_install:
cd debian/build && DESTDIR=${CURDIR}/debian/com.github.artemanufrij.webpin ninja install